W-WAN module failed check - WR41v2

Sorry for my next question - but anything goes wrong :frowning:
When i try to apply the firmware on my WR41v2 and select as W-WAN Module “13 - Ericsson F3507g/ F3607gw/F3307/F5521gw HSDPA Module” in the FlashWriter Vers. 1.0.503 and Firmware Version 52145 for WR41v2 - I recieved allways the message “W-WAN module failed check - please check you selected the correct module!”
The router PN is WR41-U7T1-DE1-ZZ and so the “13 - Ericsson F3507g/ F3607gw/F3307/F5521gw HSDPA Module” should be the correct one.
When I change the ini file and delete setwanmodule - it will apply Novatel - and this doesn’t work after apply the firmware. The modems is not running


Are you just trying to change the firmware version to a newer or older version? If so, you should be able to do this through the TransPort web interface instead of using FlashWriter.

If the above information is not helpful or applicable, please answer the questions below:

What is the name of the .zip file that you’re attempting to use with FlashWriter?

Are you using the Ethernet method of FlashWriter, or the Serial method (or have you tried both)?

I trying to apply an newer version and i received the message with multiple firmware versions:


Also i tried both methods of Flash Writer to update the WR41v2. When I select no W-WAN module or delete the setwanmodule in the ini - the firmware upgrade was successful - but then i can’t use the w-wan

If you have managed to install a new firmware successfully with out the setwanmodule. Then you can set the wan module from CLI and reset the configuration to read the relavent parts of the factory file

as this is a erricson device you would carry out this from the CLI or Web Execut commands

  1. “modemcc 0 module ERICSSON_3G”
  2. “copy config.fac config.da0”
  3. “reboot”

this will tell the router it has the Ericsson module and to copy the factory default configuration file in place.
then on reboot the router will read the entrys for that module

once the router has rebooted you should be abble to add the settings for APN / SIM PIN / Username /Password

just enough to allow the router to connect to the cellular network

if that has worked PPP shoudl come up and access over cellular.

if it has not worked then you should realy talk to tech support as the unit could have a hardware fault / module failure



I had the same problem. After updating a WR41v2 and selecting W-WAN Module “13 - Ericsson F3507g/ F3607gw/F3307/F5521gw HSDPA Moduleworking” the W-WAN module failed. Luckily I found this thread and James solution got my router up and running.
Saved my day. Thanks!