Wakeup time configuration

We are working on xbee3 micro 2.4 module and the current synchronous sleep network configuration for xbee end device as
SM: 8, SO: 2

Coordinator side as,
SM: 7, SO: 1,SP: 0x1770 and ST : 0xAF.

Here whenever we tried to configure ST below than 0xAF(175msec) by configuring commands like MT,NN and NH to achieve lowest wakeup time for expansion of battery life end device is failed to transmit data to the sleep coordinator and for 175msec the data sent successfully to coordinator side.

We want to know why it’s successfully transmitting for 175msec and not below?

What values do you have your MT, NH and NN values set to?

What is the TO value set to?

In sleep coordinator and end device we configured MT=1,NH = 2,NN =1 and TO is set to default 0xC0.

Try setting the TO command to 0x40, and the NH to 1.

Your sleep status commands should then give you the shortest time you can be asleep for the wake time.

Thank you for your replay. But we are trying to connect multiple end device and it has to send data to one coordinator that is central device within less time as possible like below 100msec(wake up time) in mesh network topology(unicast). But if we configure TO to 0x40 this will configure point-multipoint transmit and this will be different from mesh topology kindly suggest as we said above lines.

What you are describing is a Point to multi-point network. Mesh would have Routers which End devices would be joined with that are also out of range of the coordinator.