Watchport Not Detecting Sensor


I just purchased a Watchport /H Temp and Humidity Sensor for our server room. I downloaded the latest drivers 5.30 from the web site and have them installed on a Windows 2008 R2 server. The sensor and Watchport Virtual Port in Device Manager and it is listed as COM4. When I open Watchport Manager and ask it to scan for available sensors it says none are detected. I tried to manually have it identify it on all of the coms and everyone says No Watchport Sensors Detected. I’m currently running Watchport Manager Build 1.23.09 (2-22-2008) and I looked on your web site for an update to the management software but I don’t see any. Any ideas on why it’s not being detected?

Benjamin Powers
Network Administrator
Illinois House Republican Staff

Hello Benjamin,

1.23.10 is the current version of Watchport Manager. Here’s the link:

I suggest uninstalling Watchport Manager via Add/Remove Programs (called Programs and Features in Server 2008 I believe) then installing the newer version. Auto detect should be picking up the sensor on COM 4, so let me know if you still run into that issue or not.

Well I downloaded the new version. I then uninstalled the old version, rebooted, then installed the new version. When I run the Watchport manager it imidatly comes up with the Sensor Setup then gives the message “Device not responding to ID query”. When I click ok to the message Watchport imidatly closes back out. I think it still has the old manual sensor I tried to add earler and when it cant detect it it crashes out. Any suggestions?

Let’s test the sensor with other software, to see if we’re dealing with bad hardware. To do this, reboot the PC then make a new HyperTerminal connection to COM 4. Or you can use other terminal software, i.e. PuTTY if you’d prefer. Does the connection open successfully or do you get an error? If you are able to connect, try some of the supported commands as mentioned in the user guide linked below.

I rebooted and attempted to connect to the COM specified in Device manager as the virtual port but it just comes up to a black screen and I have no keyboard input. Here is the log from the connection.

2011-03-25 15:06:11 Opening serial device COM3
2011-03-25 15:06:11 Configuring baud rate 9600
2011-03-25 15:06:11 Configuring 8 data bits
2011-03-25 15:06:11 Configuring 1 data bits
2011-03-25 15:06:11 Configuring no parity
2011-03-25 15:06:11 Configuring XON/XOFF flow control

I even tried going back to the old version of Watchport Manager to see if it would let me delete the bad sensor listed in the background window but now it’s doing the same thing as the new version. It seems like the settings that I set when I was first trying to get it configured are somehow stuck in the registry or somewhere and every time I fire up the application it automatically attempts to find that sensor and when it fails just crashes. I’m guessing that if I could reset those settings back to the way it was before I ever installed it that it might let me do a scan and find it. Do you know of a settings file or anything that that could be written too?

Try uninstalling Watchport Manager through Programs and Features then rebooting the computer then trying a direct connection w/ HyperTerminal or PuTTY again. Do you get an error when trying to open the COM port directly? If not, does the sensor respond to any of the supported commands (such as “?”)?

You might also want to connect the sensor to a different computer, install the driver (not Watchport Manager), then try a direct connection there too, to give us more data points.

Thanks for your help and I hope you had a good weekend.

I did as you suggested and hooked it up to another server. This time a W2k3 server. I let the drivers from Windows update install and then tried to connect from Hyperterminal to Com3 which is that the virtual port was installed under in Device manager. When I connect it says connected but I cannot do any commands. I just get a cursor line that will not respond to any imput or returns. I then installed the version of Watchport Manager you gave me and let it attempt to auto detect it. Again it came back as no sensors detected. I went to the manual add and attempted to do an identify on Com 3 and again it came back as No Sensors Detected. Im guessing at this point it might be a bad sensor.

I agree, sounds like defective hardware. If you’d like to get a RMA setup, please create a new support case and reference this thread.

Ok i’ve registered and submitted a support case. Thanks again and let me know if there is anything else you need.

Also, should Is this going to be just for the sensor or for the USB host as well?

Even though our Watchport USB sensors are technically two components (the sensor and the host), they are treated as a single device.

Well I just got the new sensor and after some work, switching the COM ports around a bit I finally got it to recognize the sensor and was able to set it up.

My question is that it doesn’t seem to run as a service. It looks like I would have to keep a user account logged into the server so that the app continusouly runs. Is there a setting or some way of running this as a service so I dont have to kep the server logged in?

Again thanks for your help!

I’ll send you an e-mail about this. In short, there’s some beta software called SensorServ that you may want to try instead of Watchport Manager. It’s similar and it runs as a service.

Hello, if you’re running the SensorServ Beta, I would be curious to hear about it. Please drop us a note in this thread.

Even if you’re not, and you have a Wired USB watchport sensor, please post here. Digi may have other options for you.

Hi, I was trying to download the sensorserv.exe software, but download location seems no longer valid. Can someone post link to where I can download this, or alternative solution for running the watchport as a service.