Web Interface

I can’t log on to the web interface at a distant location for my Digi One SP.

While at home where the Digi One SP is connected to the router there isn’t any problem. I just type in the IP address on my web browser and I can connect to the web interface without any problem using the using my user name and password.

The problem arises, when I’m at a distant loction and enter the IP address in the web browser. I can’t connect to the web interface of the Digi One Sp

Does anyone have any possible solutions?

Thank you in advance.


You will want to confirm there is no firewall blocking access to the unit.

Try checking to see if you can connect to the unit using telnet or ssh.

See my post for your other post - will be same issue.

TCP/IP is TCP/IP and all services based on TCP/IP (telnet, Web, RealPort, TCP Sockets profile) will be affected by incorrect or incomplete router/gateway configuration.


I really appreciate the time you have taken in setting me straight on configuring my Digi SP One.

I’m trying to set it up so remote users can access the data feed that the Server is connected to. This would be an outgoing TCP connection, right?

I’ve been fiddling around with the D-Link router settings in the Advanced Tab> Virtual Server. I’m confused of what my inputs should be for the Private and Public Port?

On my Digi One SP Configuration and Management page Configuration>Serial Port>Port Profile>Profile Settings

This is what I see:

TCP Server
Connect to the following TCP ports on the network (calculated from Base Socket).
Telnet TCP Port: 2001
Raw TCP Port: 2101

So is my private port for my router setting going to be 2101? If so then what will be the Public Port?

That is up to you - you could stick to 2101 for raw TCP or pick some random value like 10001 or 42678. The problem with random ports is you may accidently select a port used by some worm or virus and while it won’t hurt your DOSP, it will make your DOSP busy most of the time ignoring requests.

The router has the OPTION to change the port as it passes through. This is of limited value for a Digi port 2101, but could be critical for Web access.

Most ISP will BLOCK incoming port 80 to prevent you from setting up a web server, so you can neither browse remotely your DLink router nor the DOSP’s web if you forwarded port 80. So you may need to say forward public port 8080 to private port 80. This means browsing to http://66.x.x.x:8080 (with your router IP in there as required) will pull up the DOSP’s web interface. The “:8080” over-rides the default HTTP port of 80 from the web browser.