what is the correct u-boot image for i.mx nano evk board?

I have purchased an i.mx nano evk board. I have manage to brick the bootloader in the emmc. I am attempting to follow the directions for restoring it found here:

I can boot fine from SD, but I have failed to get uuu to reflash the bootloader in the eMMc. I am unsure if I am using the correct image to reflash the emmc.

I have tried images that I created by doing the yocto build and also ones that are prebuilt that can be downloaded from here:


Every time I run uuu it bricks my SD card, and it won’t boot from emmc. Reflashing the SD card is easy (I’ve already done that at least 20 times).

Assume I use prebuilt images that I can download just to bring some sanity to the process: What image should I use on the SD card? What image should I flash to the emmc using uuu or some other means? Thanks.

Did you purchase and NXP EVK kit and try to use Digi images on it? Why? This is not a Digi product and those images will not work on NXP EVK. Please see NXP help page:

Let me clarify, It is a Digi ConnectCore 8M Nano SOM based on NXP i.MX 8M Nano kit. 100% Digi. Purchased from DigiKey.


Please try images and procedure from this link:

the link has archive with images and two sets of instructions:

  1. program via uuu (no sd card needed)
  2. program from uSD card

>Every time I run uuu it bricks my SD card
when you program via uuu, you should not have SD card inserted - it transfers images via USB directly to the target.

OK, thanks for the help. Here is what ended up working for me:

get the install_linux_fw_uuu.sh script from here


edit this script with your image name if it is different from whats hard coded in the script, but don’t change the imx-boot-ccimx8mn-dvk.bin

connect with serial terminal (8,N,1 115200)

dip switch S1.1=on S1.2=on S1.3=off S1.4=off

Press reset button on DVK board

uuu imx-boot-ccimx8mn-dvk.bin (host terminal)

hit enter quickly (serial terminal)

fastboot 0 (serial terminal)

./install_linux_fw_uuu.sh (host terminal)

you will see this in the window that runs uuu:

Success 0 Failure 0 Wait for Known USB Device Appear…

you will see this in your linux serial terminal:

resetting …

dip switch S1.1=off S1.2=off S1.3=off S1.4=off

Press the reset button

Device will go through two boot cycles

You should be at a shiny new login prompt running from emmc now

I sent the same question via email to Digi. They replied in pretty short order with instructions to use the install_linux_fw_uuu.sh. That combined with your comment to leave out the SD card did the trick. Boot from uuu and run the .sh script