Uboot Lost on CCMX51 with Jump Start Kit


I am currently working on a CCwimx51 with Jump Start Kit Rev D and linux solution.

I tried to mount mtdblock0 manualy with comman line : sudo mount -t jffs2 /dev/mtdblock0 /media/mtdblock
I heard a little noise during mounting.

After that, Board was no more able to start. I think NAND flash has been formated and I have lost U-Boot.

I tried to start Board in serial downloader mode but with this revision of Jumpstart kit, there is no way to configure bootstrap and boot mode pins.

I have reed, in IMX51 Reference manual, that when no valid image is found, cpu automaticaly switch to serial downloader. But I never succeed to connect…
Is there a special serial configuration?
Is there commands or actions to do?
Is there locked fuses that makes serial download impossible?
Is there a solution to restart my board?

Thanx for help.


Hi ,
According to my knowledge , 55001488-02 Rev A Development board is there. Could you please send the
Board number and software ISO image version (Like 40002739_A).
From where you got the IMX51 Reference manual ,you mentioned that “no valid image is found, cpu automaticaly switch to serial downloader” , could you please send the link for that document.
If you think that U-Boot lost , you have to contact nearest digi sales person, may be they can replace the development board.
It looks like U-Boot lost.

Waiting for your reply.


Hello, and thanx for reply

I have contact my digi distributor who answers that, as long as board is early available, there is no way to make an replacement of base board…
So, I sent my board for reconditionning and wait…

thanx again



PS : Reference manual MCIMX51RM
Section 9.4.3 Serial Bootloader