Why can't the XCTU program find the modules?

I downloaded the latest version of XCTU and connect an XBee module to the XBIB interface board and connect the board to a computer USB port. I try to detect the model with the XCTU program, and it tells me there is no module. I tried with several modules and several ports, with the same results. However, the XBee white adapter does show up, and that is the only thing that appears to work. Are all the other modules defective or is it a problem with the XBIB-U-DEV? I don’t have another XBIB board to try, so how can I know for sure if the problem is with the XBIB board or the XBEE modules or both?

There are several scenarios in which your XBee will appear to be non responsive, one being a port mismatch, speed is usually the culprit. You can try the second button at the top of XCTU which is ‘discover radio modules connected to your machine’. This can scan the module at different port speeds. Or you can hold the reset switch on the XBIB, the top middle button, while you insert a module then release once inserted while XCTU is searching for it. This has worked for me many times.


Okay, I already tried the ‘discover’ button, and it does not find the module. I tried the re-set method and that did not work as well. We have a white XBee adapter that does seem to work, as the machine detects that. That is the only thing, out of all our Digi devices that the XCTU program detects. Apparently the XBIB-U-DEV board is defective and I have plugged it into several ports, with no success. I also tried the XBIB-R-DEV board, but that board doesn’t seem to like the XBee modules as all the LEDs flash on and off. With the XBIB-U board, the red LED flashes on and off, the green and yellow LEDs next to the USB connector are solid on, and three LEDs on the board are on: DS4, 5 & 7. I don’t know what this means.

Correction: LED DS2, not DS7. DS3 is off

The XBIB-U board is a rev A, by the way