WR21 will not reconnect

I have a WR21 which is configured for MultiTX to connect to connect to an IP address and specific port. It will connect once, but then if the connection is dropped (it might be aborted by the listening server looks like server is sending an RST), it will not reconnect to that IP address and specific port. The MultiTX setting is set to reopen closed connections and the Socket Inactivity Timeout is set to 0.

Any ideas on how to fix this?


Have yo checked with the anyliser trace if there is data coming in on serial and if the transport is trying to re-open the connection.

is the server closing the socket because of inactivity? might be worth setting the inactivty timeer on the transport as well



The analyzer trace and the event log show that sometimes there is data coming in to the serial connect from externally attached hardware when the connection is trying to be reopened but not always. I have tried this with nothing attached to the serial port also with the same issue.

The server is not closing the socket because of inactivity, in one case it had aborted it and sent a RST command because it had received malformed data and then the modem would not reconnect. We fixed this by not aborting the socket but closing it. In another instance we pushed new software for the server (the fix I just spoke about) when broke the connection and the modem would not reconnect. I have also tried setting the inactivity timer on the transport to 30 seconds, which did not help. The WR21 will still not reconnect.

If I leave the WR21 turned off for a few days it will reconnect.

Do you know how the WR21 handles an RST command?


Hi Doug

Just did a simple test over ethernet interface that from a wr44 to my PC and NETCAT listening on the PC

if i start netcat -l -p 54321 and sent traffic over the serial interface the characteras appear and can see the transfer in the anyliser

if i kill netcat

i can still see the attempts on the transport trying to send data even though it gets resets on the port

if i restart netcat

the transport connects and passes data

are you sure the server thats not allowing the connection.

if the problem is the transport a reboot would clear it you should not need to leave it for a period

that would give the idea a timer in the network or the server



I looked at the event log and the unit is trying to reopen the connection as it is supposed to. Using wireshark on the WR21 shows that is sends 20 syn’s then sends an RST. The issue is that they do not appear to be getting to the intended endpoint. Is there some way I can check to be sure that they are actually coming out of the WR21?

In one case the WR21 had lost connection, was trying to reopen it and finally after 10 hours was able to reconnect.

In another case we have turned off the WR21 for about 45 minutes and it was able to establish a connection when it came back on.

Not sure what is causing this. Any help would be appreciated.

It does sound like a connectivity issue

when you are not getting the data to the server just check to see if the router can connect to the internet
try a multi ping (5,10) to google ( if that does not respond then try to reset the PPP interface

from CLI

PPP 1 Deact_rq

you might need to look at surelink wizard to provide connection checking and reconnecting



James thanks. The WR21 can definitely reach the internet as I can log in to it via HTTPS access.

I will look into Surelink also.