WR21 Realport

Hi Guys:

My router:
TransPort WR21
HW 1201a

Ok, we’re using realport from a Windows 10 x64.
Realport versin is 4.7.410.0.

We are using OpenVPN on the computer as a server and having the Digi connect to the server over the OpenVPN, that part works just fine, perfect in fact.

Here is our problem. I go to device manager, select Multiport serial adapters, S9Digi(that is our name) and select properties. In advanced I click properties and then click on Port1(Com10 in our case). On this page you see a small box called port status and the item in question is “Device Port:” which has a rest status of “Not acquired”.

Here is the problem, after a Digi reboot and VPN reconnection, which takes about 60 seconds, netstat -a -p tcp -n shows connected, the real port is up. It shows as connected in Connections-IP Connections on the digi as well.

When I open up our application on the computer and try to connect to COM10, the Port Status changes to “Aquiring…(Xth try)” where X continually counts up and the application continues to attempt the connection. If I open up a cmd.exe session and type mode, only COM1 appears. As soon as the application’s connection attempt times out, I type mode and COM10 is there.

The only way to fix this is to go into the Digi-Configuration-Network-Interfaces-Serial-Serial Port 0 and do any of the following:

  1. Toggle “Enable Echo”, OR
  2. Toggle Flow Control" to HW or to None…or None to HW,

Click save and then I attempt to connect using my application and it works fine. It will continue to work fine until the router reboots, after which I need to do one of the methods above.

Does anyone know w trick on how to get the Digi to do this itself?


Does unplugging and plugging the serial cable achieve the same thing?

Also what does an analyser trace of the serial port show when you attempt a connection?

Removing and reconnecting the serial cable has not been tried.

The Analyzer trace shows nothing, there is no data since the device connected to the router does not send anything unless polled. Since the COM10 cannot come up, there is not poll so no data coming from the device.


Hi Guys;

What can I do via telnet to toggle the HW flow control on serial 0? What would the commands be? I tried testing this form ssh but the manual is not very clear on this. Specifically, I could not find a command to show me the “current” serial port settings as I want to change that before changing anything.

Any tips on that?


Connect to the device via telnet/ssh.
Change your port to port 0 with “AT\PORT=0”
Change what ever you like with the AT commands.
You can view the serial config with “AT&V”.
Flow control is “AT&K=x”.
You save the serial data with an “AT&W0” but if you are only bouncing it you wouldn’t need to save.

There is some more info on page 115-124 of the manual and on page 269.