XBee 868LP - 1774 - Not found in XCTU

my XBee868LP got crashed while I did an Firmware update.

I tried to reload the Firmware Version 1074, after that the module didnt restart and now I can communicate with the Module.

  • I tried Commisssioning Buttun if module is sleeping
  • I tried with Reset button
  • If I start the XBee Recovery it starts end terminates immedeatly again
  • If I trie to load the radio configuartion XCTU tries to update the radio firmware library but it crashes by doing that and sais lost connection.
  • With “Add a Radio Device” the module can be discovered
    Function: 1774 - Not found in XCTU

What can I do to Recover the Radio Module?

The answer is that there is a bug in the 1074 firmware. The DD field, device type identifier, needs to be set to the value “C000” or the firmware update with version 10xx will end up as 17xx, which does not exist in the library and the function will not be recognised by the XCTU software.

Try to optimize your system’s USB settings and then attempt XBee Recovery again: