XBee and other 2.4Ghz devices interference

How can I make XBee/Pro less sensitive with other 2.4Ghz devices such as telephone, Microwave, X10 video sender, etc… My XBee-Pro module won’t work when any other 2.4Ghz device is operating.

You’ll need to adjust the CCA or clear channel assessment value to allow for the additional interference caused by their X10 Video sender.

With respect to microwaves and cordless phones, we haven’t observed any interference issues with these devices.

Thanks MichaelT. You are correct on the microwave and cordless phone. I did more testing and isolated out the X10 video sender is the only source of interference. I tried to adjust CCA values from 0-0x50 as you suggested, but i still could not find any value that can fix the interference problem. Do you have any other suggestion ?
Thanks in advance.

The XBee Series 1 will allow you to perform an Energy Detect (ATED) that will report interference on each of its channels. This will then allow you to select the most adequate operating channel to avoid the interference altogether. If that isn’t sufficient, then you must simply use the mechanisms in the radio to operate within the interference as best as possible. The CCA is one of these mechanisms. You can also set the RR parameter (available in firmware version 10Ax and above). This will retransmit information if it is interfered with.

Hope this helps.

Is there a way to use XCTU to access the Energy Detect (ATED)?

Where is this ATED tool?