XBee Code Development


I’m a student, and I am currently working on a project in which I need multiple XBee modules to communicate with each other without the help of a computer.

I downloaded the XBee Code Development zip file (1011.zip) from http://www.digi.com/products/wireless/point-multipoint/xbee-series1-module.jsp and I followed the instructions in the manual (BeeKit Code Development.doc).

But after installing all the required programs, I can only find the Wireless UART project template in BeeKit.

After I export this project, I can compile it with CodeWarrior. But after CW is finished with making the project, X-CTU doesn’t start, and I cant select anything else than the standard function set “XBEE 802.15.4”

I’ve gone through this manual a lot of times, and I can’t find what I’m doing wrong.

I am using Beekit 1.7.0 and CodeWarrior V6.2 SE.

Can anyone please help?

With kind regards,

Geert-Jan Smulders

What operating system are you running on Windows?
If so have you tried the X-CTU program to program the XBee modules?

I’ve found this post:
I tried it. And now, I can make a project whith BeeKit that supports XBee.
But unfortunately, I’m getting a error message, saying that I cant use the Export method, because I need a license (see attachment).
The strange part is, that I’m creating a projects using a SMAC codebase. And that should be free.

Is anyone else programming the XBee at this moment?
And if you do, can you please tell me what I’m doing wrong, or how you have set it up?
Because I’m all out of ideas.

I’m running Windows XP SP3.
In the “Modem Configuration” tab of X-CTU, I can only select “XBEE 802.15.4” as Function set (with “XB24” as Modem)


Maybe nobody’s interested, but I still going to post it anyway.

I’ve finally found the zip file “XBee_Code_Development.zip” at http://www.pudn.com/downloads74/sourcecode/embed/detail265087.html. The site’s in Chinese, but I used Google translator. There I could download the zip file.

All I need now is Freescale SMAC 4.1, but only SMAC4.2 is available on the Freescale website.

Does anyone have the 4.1 zip file?

If not, I will keep you posted.