Xbee pro s2 API mode mesh configeration

hello every,today i had test the Xbee module’s api mode,but when i set the module to API mode ,make sure the PAN_ID,and DH,DL was correctly
set,but the connection was not builded.
when i change the module to AT mode ,the configuration is the same as i was seted in API mode ,the connection was builded ,and communication works fine.
What is the problem?There is something wrong about my configuration?
Waiting for you help,thank you.

Oh… In API mode to transmit the data, data to be entered into ZigBee Transmit request frame. In this frame you can also set the destination Mac address to enable Unicast mode.