Xbee Pro XSC S3B, Unable to enter API Mode

Hello Digi,

I am finding it impossible for my S3B devices to enter API mode. I have tried the commands:

ATAP = 2

And all it does is return ERROR!

I have enabled the API Flags and the Escape Sequence Char Flag.

~ Please Help :smiley:

~ Jacob

Hello Jacob,

Do you receive the OK after the ‘+++’? Also, once you send ATAP2 you should receive OK and then you must exit “command mode” by sending “ATCN” (and receiving OK).

If you are not receiving any confirmation, probably the COM port is not configured well (try Baud 9600 or 115200, No Flow control, 8 Data bits, No parity and 1 Stop Bit).

Also, I’d recommend to configure it with X-CTU program, you can find it here. Best regards,

The +++ returns an OK but the ATAP2 returns nothing or returns an Error. We have yet to receive an OK from ATAP2

Hello again Jacob,

Try to change the setting with X-CTU but from Modem Configuration tab. Were you able to set any other settings? Are you using the latest firmware version for your module?

Best regards,