Xbee Router two direction

I have three Xbee S2C in AT mode
I am using first one as coordinator and second one router and the third is as end

I configured the end to send to the router and the router sends to coordinator.(end -> router -> coordinator)

but when the coordinator sends no data will arrive to the end.

how can I make the router able to send in the tow direction?

I need is as following Coordinator <-> Router <-> End

What commands are you adjusting? The DL and DH values tell the radio that what ever data is received on the UART, to send that data to the module with that matching SL and SH or to all modules (Broadcast). If you want the end device to send data to the Coordinator, then you should set the Dl and DH of the end device to 0. If you want it to rout between the Router to get to the coordinator, then the process for allowing that to occur is as follows:

Power on Coordinator
Power on Router and allow it to associate
Set NJ on the Coordinator to 0.
Power on the End device.

The end device will join the router as it is the only parent device then allowing joining to occur. By doing this, you can be assured that all data going to and from the end device will pass thru the router.

thank you very much
it works now.

sorry it doesn’t work

first power on coordinator with NJ= FF
then power on the router and wait until associate
then NJ = 0 in the coordinator
after that I power on the end device

the DH and DL in the End equals 0

first I tried to communicate using XCTU between the Coordinator and End , the data is sending (work)
but unfortunately when I turn off the router it also work
I assume that the data is transfer with out passing thru the router!

That would be correct. Your end device is associated to the Coordinator. You need to follow the steps I outlined above.

That is power on the coordinator and let it come up. Power on the router and allow it to associate with the coordinator. Turn off Joining on the Coordinator by setting NJ to a 0 value. Power on the End device. The end device will then associate with the router.