Xbee s2c not writing to serial in API mode after receiving frame

All Xbees are set to API mode and are shown to be in the network in the XCTU program.
I connected on to the desktop and write a frame in XCTU to the corresponding Xbee.

There is no serial output on the Corresponding device.
I have tried on a Raspberry Pi 3 using a SparkFun’s XBee explorer dongle (www.sparkfun.com/products/11697) to read form the Xbee could not read or connect to it using minicom, screen, c code and python code. It did not work.

Next I connected the xbee to the GPIO pins in the Raspberry Pi to check if it was the dongle, it was still not communicating with the xbee.
The xbees were still shows to be communicating with each other since RSSI was HIGH when frame was sent.

Another try using arduino. I wired it so that the connection were correct. There was no serial data being read.

The XBee serial interface configuration:
115200 baudrate
No parity
1 stop bit
3 character times for packetization timeout
CTS flow control is disabled
RTS flow control is disabled
API mode is enabled
API output mode is native

I am thinking that it might be the configuration not sending the serial buffer when it receives the frame.

Any help would be appreciated.

May I suggest you remove the XBee from the picture and simply run jumper wires from the two boards. Then use the terminal of XCTU on the PC to monitor what is being sent out of the Pi. I suspect you will find that either you are not opening the correct COM port or something of that nature.

I had pretty much exactly the same issue as rmuno039: Xbee S2C TH (programmable), Raspberry Pi 3 using SparkFun XBee explorer dongle, same config, RSSI lights up on Rx - but no serial comms to Ruby program or minicom. Also, all of this worked before using XBee S1s.
Anyone run into this problem?

I found the solution in the another forum with the same problem but I could not find it now.

From what I remember you have to tell the chip to go to the saved state.(Found this today) link: https://askubuntu.com/questions/941631/serial-communication-between-raspberry-pi-3-and-xbee-s2c-through-sparkfuns-xbee/1052452#1052452

You just right write a ‘U’ and ‘B’ to the serial port at the beginning.
If i remember correctly that is all you had to do if not set the baud to 9600 and the raise it.

The other link explained more about why (if you need to know why you can look for it)
Hope it help

found the link