xbee s6b turned into a brick after an update

I updated my xbee s6b with X-CTU, and it’s not working anymore after that. I cant read or write parameters, i just can write/update firmware again, clicking option “Always update firmware”, but after a successful update it continues with same behavior. XCTU is showing me next comments after trying to write parameter with such option:
Getting modem type…Programming modem…OK
Failed to enter command mode
Found bootloader active reprogramming firmware.
Write Parameters…Failed
Any idea? Firmware to update is wrong?

Sounds like the baudrate changed? Probably defaulted?
Go back to the PC Settings tab and keep doing the test/query on the different baudrates to see if it works?

I got a similar error when I was doing an update but a reset/power cycle solved the problem.

I can update every try, keeping reset signal of my x-bee development board, and leaving after trying to read/write parameters but always reading/writing parameters process fails.
I tried every baudrate speed and it’s not working anyway. it’s look like always is waiting in bootloader …
Working with x-bee S6BSM, XB2B-WF set, and XBee Wi-Fi (S6B) Development Kit

Any other idea?

Thanks a lot

I had a few XBees that it would let me set the firmware but none of the AT parameters. I ended up declaring them dead unfortunately…

I got to recover in the end, two devices. They turned into a brick after updating … but I dont exactly the way to recover, just being stuborn, updating and updating xbee, keeping reset button pressed before update until message asks me to reset device, and with default parameters also …

Thanks for your support guys!