xbee series2 no output on uart


I have a small setup which worked, consisting of the following:

  • arduino with a sensor, measuring distance
  • arduino sends measurement to xbee series 1, on an adafruit adapter
  • receiving laptop, with another xbee series 1, on an adafruit adapter with a FTDI cable, receives the measurement, i.e. the sent data is received/seen in the minicom terminal.

Simply put, this worked fine. Until I burned one of the xbee modules. I ordered 2 new ones, but Xbee series2 this time.

I configured the series 2 according to the Chat example available on the Digi website. I configured the one on the laptop side as coordinator, the one on the arduino side as a router. So the X-CTU module allows me to communicate with the modules fine. No problem there
I replaced the old xbee modules by the new ones, and I can see the red leds on the receiving (coordinator) xbee module lighting up. So as far as I can tell data transmission is working.

Now my problem: the minicom terminal connected to the coordinator Xbee module (the one with the red led lighting up when data is received), doesnt’ give any output anymore.
I don’t see what can be wrong?

Any clues/help please.

thanks a lot

Are you using transparent mode or API mode? If you are using API mode, make sure the API frames you are sending to the radio are valid frames for the XBee ZB modules as they do not use the same API interface as the XBee 802.15.4 modules.

Are you able to do a Node Discovery from the Coordinator and see the router?

Hi thanks for your reply.
I’m in transparent mode. If I issue the ATND command, I don’t get a reply. So it seems something is still wrong in the configuration I’ll check. The strange thing is that when the transmitter sends, the red led on the adapter containing the coordinator module, lights up.

What is the full part number of the modules you are using.

When I connect the RX and TX pins on the router side and type in the coordinater terminal, my message makes a round-trip. So the XBEE communication seems fine. So there must be a problem on my arduino board, I’ll try to find it. thanks for your help