XBEE WIFI: Timeout to connect access point

I’m new and doing a project about XBEE wifi

now I use X-CTU to set the parameter of wifi module.
but when i chose active scan,
and click the “selected AP”, it always told me :timeout to …

and when i check the Association Indication,
it shows 27(SSID was found, but join failed)

does it mean the module is broken ?
or there is some problem i didnot find.

Thanks for reply!


Are you able to communicate with the module with the Test/Query function in x-ctu? Have you tried connecting to a non-password protected wifi hotspot?

Hi tengyi

If you are using DHCP addressing mode in your module then try checking with the DHCP settings of your router.

Thanks for reply~
At that time, i tried many times but failed.
At last, when the router was close to the wifi module. it worked.
Then i added a antena for the module. it works well now.

Hi, im using static mode.
Now the wifi module works , thank u ~

dear all

I am still facing the problem of connecting the Xigbee to any AP or even a private hotspot.
Everytime i try to select AP, it shows the error “timeout”.

Do tell me if there is any solution to this.