xBee zb sending packets with unknown NWK cmd IDE?

Ey :stuck_out_tongue:

Im trying to make a bind between a cc2480(2006) and an xbee-zb (stack profile to support 2006). The connection is established but with a sniffer im getting some trash… packets with an unknown command… I mean, without send anything (absolutely nothing) im getting packets with a specific period with the following MAC payload:

09 10 58 8B 00 00 01 11 CE 14 3E 40 00 A2 13 00 04 60


NWK Frame Control: 1009 (frame type NWK Command)
Source Addr: 0x0000 (coord)
Destination: 0x8B58 (the only endpoint connected)

and NWK payload: 60 04 00 13 a2 00 40 3e 14 ce
where 00 13 a2 00 40 3e 14 ce is the mac addr of the endpoint, but what about 60 04? there is not NWK command id with 0x60 :S

Look the screenshot here

By another hand i’ve some theoretical question about the application profile implemented on the ZB Stack.

A device can get more than one endpoint, but xBee-ZB only allow me tu use just one, is it? but why there is like two endpoint identifier, one call ZigBee Source Endpoint, and the other Zigbee Destination Endpoint?

If i didnt catch wrong the Zigbee working mode, an endpoint can have more than one cluster, is it? but I only can see a command to change a single cluster ID… why?

Another though, a cluster can have more than one command, is it? where can i add them on the ZB?


problem solved… the problem was caused to the sniffer… on the top of the program there is a listbox to select the zigbee version, by default just after load the program it is set to 2003 Stack, we must select 2006 obviously…

I need your help,

I want to start a new network with xbee modules (one of then XBEE usb as coordinator) and Texas cc2480 (demo kit ez430-rf2480). I have been configured my Xbee Coordinator as follows:

Firmware: XBP24-ZB (Zigbee Coordinator API)

ZS = 1 (Zigbee 2006)
AP = 1
AO = 0

The Texas modules has the application ZASA installed but my Xbee Coordinator can´t discover these nodes. The Texas modules only see its texas Coordinator.

What profile in Xbee coordinator are you using?


ive succeded to get working a comunication between cc2480 and xBee ZB (USB). Im using a private defined profile, anyway it doesnt matter because xbee won’t care… Mmmm honestly i dont have so much idea about your problem since i didnt test it around node discovery, but i think there is a command on cc2480 to set the table that defines the discovery answer, as well, dont forget to look around all the commands for timeouts on the xBee…

If you need anything more don’t mind to write me on a private message.

Im using ZS = 1 on my coordinator (xBee)

Using XBee Zigbee Coordinator API firmware on your module will allow you to setup your Zigbee network, since that’s the Coordinator’s job.

Something that concerns me is the use of ZS=1 and the fact that your module is currently associated to the TI coordinator. Are you sure the TI module is using Zigbee 2006? Have you tried turning off the TI Coordinator then dis-associating your TI module to see if it associates to the XBee Coordinator??

yes, cc2480 is 2006 stack… if you dont set ZS=1 it wont work (tested hehehe)