Xbee3 LTE PING server problem

I am working with the Xbee3 LTE-M modem and trying to get basic stuff working.
I am sending AT commands via UART RX and TX lines. I can send several basic commands and get correct results: like ATIM, ATDB 0, ATDT 0
However, I am unable to ping a server.
I am sending:
sendAT(“+++”); // this works and get OK
delay(1500); // wait 1.5 seconds
sendAT(“ATDL www.digi.com\r”); // this works and get OK
sendAT(“ATDE 80\r”); // this works and get OK
sendAT(“ATPG www.digi.com\r”); // this does not work and get ERROR

I’ve tried different servers, IP numbers etc. Nothing works.
Am I missing something?

This sounds like your SIM card and account do not have external access to the internet or you are not connected to a tower. Have you verified that you are in fact connected and have an internet connection by querying the AI and CI commands?

Thanks for the help. You were correct, AI indicated not connected. I updated firmware and AI returns 0. I am able to ping.
But I have another question. I am trying to send a GET request following the example in the Xbee3 User Guide (p.33), but it is not working. My commands are attached. What am I doing wrong.


I would suggest looking closer at the directions for the HTTP get function. Make sure you are going to the Hex option and appending the packet as it outlines.

Thanks for your info. I am not using the XCTU software to send these AT commands. Our application won’t be tethered to a Windows PC and we need to interface the Xbee modem with a microprocessor. So I am doing basic UART communication over the TX and RX lines. I did connect the Xbee to the XCTU software as a first step to go over some of the basic examples. One of which was the GET request.
I tried reconnecting the Xbee 3 (XB3-C-GM1-UT-001) to XCTU and re-performed the GET test. It connected and I received the correct response, but it worked about 10 to 20% of the time (signal strength = 65 to 67 so 4 bars). AI = 0 so connection to internet. Unfortunately the XCTU is a bit of a black box and does not show what steps it is taking when sending and receiving the GET command.
Any thoughts?

The terminal function of XCTU is just that. A terminal. It only does what you tell it to do just like you would if you were sending it from a processor.

For example, if you want to enter command mode, you would issue a +++ within the guard time preceding and ending with the guard time of silence.

You will get an OK when you are in command mode.
Next, if you wanted to read the destination address, you would issue an ATDL
The response would be the DL and the address.

To send your data, you would just send it just like you would if you were connected via a cable.