XCTU "Could not find an update node.

I’m trying to do over-the-air radio firmware updating with XCTU.

I’m trying to update an XBP24C ZigBee Pro module from 4053 to 4055.

XCTU is connected to an evaluation kit board that is configured as a router.

I’m was able to perform firmware updates on the coordinator and a router.

However, when I tried an end device I got"
"Could not find an updater node. > Error executing ZDO command > status: 132.

The end device is configured to use pin sleep, but it’s being told to stay awake.

XCTU is able to display the correct configuration of the end device.

Any ideas of why XCTU can’t do the firmware update?

Try changing the sleep mode value from pin sleep to cyclic sleep.

Thanks for the suggestion. Unfortunately, I still get the same error.

Do you know what the error messages mean?


What it means is that it can’t find a parent node in which to receive the OTA update from. Are you trying to update the code on a Coordinator?

My network looks like this:

MAC,Role,Network Address,Parent,Last scan,Connections
0013A20040C6814E,Router,D26F,7,“0013A20040672539 Coordinator [0000] 254 Active,0013A20040C4C75D Router [70F8] 255 Active”
0013A20040672539,Coordinator,0000,7,“0013A20040C4C75D Router [70F8] 255 Active,0013A200406726B5 End_device [D439] 255 Active,0013A20040C6814E Router [D26F] 255 Active”
0013A20040C4C75D,Router,70F8,7,“0013A20040C6814E Router [D26F] 255 Active,0013A20040672539 Coordinator [0000] 255 Active”
0013A200406726B5,End_device,D439,0013A20040672539,6,“0013A20040672539 Coordinator [0000] ? Unknown”

D26F (router) is attached to the PC and XCTU.
I can update the firmware in all the devices, except D439 (Device).

Try selecting the parent node for the end node as the updater.

I don’t know how to “select the parent” node. Please explain how you do it.

However, I did get it to update. Here are two ways that I used, one that works and one that doesn’t.

The way that doesn’t work:
o Add the “wired” eval board to XCTU.
o Display the network graph using the button in the top right of the window.
o Double click on the device you want to update.
o Select download.
o Get: - Verifying that the firmware binary exists… [OK]

  • Finding a good updater neighbor… [ERROR]
    Could not find an updater node. > Error executing ZDO command > status: 132

The way that does work:
o Add the “wired” eval board to XCTU.
o Click the network button on the “wired” radio module (left column).
o Add selected devices.
o Double click on the device you want to update.
o Select download.
o Get success.

Thanks for your help.

It seems like both ways should work. I was able to update the coordinator and routers. So, I think it’s a bug.

In any case, I’m happy to have a way that works.

Thanks again.

There are severall ways. First issue an MP command and then look for a router that is in range with a matching 16 bit network address.

Next, try using the FN command.

Third, try using the Network map function in XCTU.,

I know the parent of the device that I want to update.
What I don’t know is how to tell XCTU which parent to use.

Is there a way to specify the parent when using XCTU?
Is there another way to do the firmware update without XCTU?

Also, I’m not familiar with the “FN” command.


In the New version of XCTU, not that I am aware of but in the Old version (5286 and below), yes you can do it in the Remote configuration tab.