XStick ZB cannot act as coordinator

Hi. I have got a XStick ZB, it can be used as router and will function correctly. However, if I flash the coordinator API or AT firmware, the module will not work. X-CTU will not recognize it as a coordinator but as unknown. Other routers will not join its network.
I have another XStick ZB which works well. So I guess this one is broken?

The XBee ZB XStick comes per-configured as a Coordinator API. IF yours has a different function set installed, then someone has changed the firmware on it.

Try using the over the air firmware upgrade function in XCTU to change the firmware on the XStick.

Thanks for the suggestion. I have checked the firmware once I got it and it was coordinator but it wasn’t working. I flashed it as router and it’s working correctly. Then I flashed it as coordinator, it still won’t work.

That would indicate that you already have a Coordinator on the network so leave it as a router.

I’m sure that it was the only coordinator in the network. Also, it was not acting as a router. We finally sent it back to digi, they refused to give us a replacement and tried to fix it and we got it back today. But it’s still not working.

How it is not working? That product comes as a Zigbee Coordinator with API firmware installed. That means that XCTU must have the Enable API function enabled for you to read it.