ZNET Routers not... routing?!

Hi Guys,

I want to extend the reach of the XBee Pros inside a site.

So I have a coordinator ‘A’ (XBP24-B ZNET 2.5 COORDINATOR AT) which is configured as ATID = 234, and the DL/DH address of module ‘B’ (XBP24-B ZNET 2.5 ROUTER/END DEVICE AT).

‘B’ is connected to a microcontroller which merely echoes everything it receives.

Leaving these running I send a message every 5 seconds, wait till I get it back, then run the AT command ATDB to get the signal information.

I move ‘B’ until the signal drops to around 30% signal strength (-71dBm)

I then plug in another module ‘C’ (XBP24-B ZNET 2.6 ROUTER/END DEVICE), and place it somewhere between the ‘A’ and ‘B’.

My expectations were that the signal strength would improve? As ‘C’ is much closer, and ‘A’ would use it to improve the signal?

The signal strength does not improve at all.

Am I assuming something incorrectly? Is ‘A’ still going directly to ‘C’ as it is still in reach? Do I need to move ‘B’ out of sight of ‘A’ then try again with ‘C’?

Any help would be most appreciated! Thanks! :slight_smile:


…just moved ‘B’ out of the range of ‘A’, then put ‘C’ in the middle and it still wouldn’t send the message between the two of them…

What am I missing? Isn’t this exactly what a router should do…???

Both Znet and ZigBee use their own logic to decide when to ‘route’. Since Digi doesn’t use ZNet anymore, few Digi people will likely answer this.

For example, if “A” prematurely used “C” to get to “B”, yes your signal is better but you’d be comsuming more than twice the RF bandwith and cutting performance in half. So don’t expect A+B to use C just because there is a weak signal between A & B.

In your last experiment with A & B being ‘out of range’, that is even hard to know. I’ve had 2 ZB node with NO clear line of site - one node is up a hill and around a building from the second in a basement, and they still insist on talking directly, ignoring multiple routers in between & yet do talk quite well.

Not knowing Znet much, there might be some time delay between when Znet loses connection & finally does a new discovery. If your micro+Xbee is an end-device, it will take some time to give up on it’s parent (aka: node “A”) and won’t automatically re-parent to “C” as rapidly.

There coudl be other settings causing problems - if there is a JV setting, put it at 1 not 0. I’m not sure what else to suggest.