300 bps communication with XBee

Is it possible to communicate with XBee ZNET 2.5 on 300 bps? I have read in datasheet that supported baud rates are from 1200 bps. But in datasheet is also said that any value above 0x07 will be interpreted as actual baud rate.

Yes, the baud rate is able to be set to 300 baud, or any other baud up to 1Mbps actually. To set the non standard baud rate, you must set it through the terminal tab using AT commands. You’ll do this by setting the BD parameter to the value you want, namely 300 buad. All paremter values must be in hex however, so the value we will set it to is the hex equivalent of 300, or 12C.

In the Terminal tab of the X-CTU, enter command mode by entering +++.

The module will respond with an ‘OK’

Set the baud rate, by setting the BD parameter to 12C by keying ATBD12C.

The module will respod with ‘OK’

Write the paremter into no volatile memory by issuing the write command by keying ATWR.

The module will respond with ‘OK’.

Now the radio is set to 300 baud. To be able to communicate with the radio again through the X-CTU, manually set the baud rate in the PC Settings tab to 300 as well.

I have tried that before, but I did not use atwr command at the end. Now, I have tried with 2400 bps first (+++ “OK” atbd960 “OK” atwr “OK”). Everything is OK. I can communicate at 2400 bps.
Than I have tried for 300 bps (+++ “OK” atbd12c “OK” atwr “OK”). I cannot communicate at 300 bps.

Now because of the atwr command, I cannot restore factory settings even after XBee power off/on.

Is there any hardware settings restore (with some pin or something)?

Sorry, but that also does not work.

First, I have set 2400 bps (+++ “OK” atbd1 “OK” atwr “OK” atcn “OK”). Then I have tried to flash firmware (9600 bps, BX24-B, ZIGBEE ROUTER/END DEVICE, check box Always update firmware). After I have pushed write button there was a message (at the bottom of X-CTU window) “Getting modem type”. It failed to get modem type.

I also have tried to flash firmware at 2400 bps. Modem type was received, but it fails to write parameters.

Thanks, Milan

You should always be able to restore the defaults of the radio by reflashing the firmware.

Under the PC Settings tab, return the baud rate back to the 9600 default.

In Modem Configuration, Select your radio from the Modem drop-down list. Selcet the appropriate firmware from the Version drop-down list.

Check the box labeled Always update firmware.

Click the Write parameters button.

The firmware reflash should commence. The radio will reflahs to the default state of the firmware you selected.

Apparently, there is a bug in the firmware that will not allow the baud rate to be set lower than 400. This bug should be fixed in the next release of firmware. The firmware will be version 1x42. Please check the website for updates when the firmware is available.