Changing Baud Rate with API mode


i have 3 questions.

My first question…i have tried all of the baud rate(0-1200,1-2400,2-4800,3-9600,4-19200,5-38400,6-57600,7-115200).from 1 to 6 exist no problem…but with 7-115200,it doesnt work.i show you the pics.a bit odd.where ist the problem?(pic1 pic2 pic3)

My second question…in PC Settings Tab exist a baud rate 230400,how can i set this value?(pic4)

My third question…can i set an any value as baud rate?for example 360000.if it can,then how should i set it?

i am working now a programm with that,i want to try every thing exactly.

Thank you~~~^^


I know this is an old post, thought of replying.

- The Baud rate-115200 depends on the XBee modules(Series-X) which you are using.

- If you are using X-CTU, you can set only the values(Standard baud rates) which appears in the drop-down list of BD parameter.
- You can also use putty which allows you to type the Baud rate.
- Just try with the X-CTU, in terminal try to set BD(ATBD)=hex value, and ATWR.