Changing Baud Rate with API mode

i have a question.
i want to change baud rate with API mode…now the baud rate is 3-9600(default)…i want to change it to 1-1200…
i have writed with API mode in HEX

“7E 00 06 08 01 42 44 04 B0 BC”.

but this is not right…
who can help me?
thank you~~

for 1200baud you need to set BD=1 so it would be more like
“7E 00 05 08 01 42 44 01 xx”
with xx the checksum, which you need to calculate.


Thank you for your help.

I have already tried this packet(7E 00 05 08 01 42 44 01 6F ) too,but it is not right.:frowning:

I show you 3 pics.

1.Send Data: the response(Hex in red-color) looks like correct.
2.PC Setting: i have set “Baud Rate” to 1200 in PC Setting Tab.
3.Modem Configuration: when i use “read” to see all parameter,then ist failed.

if i make connection again,the Baud Rate changes automatic to 9600(default).

where is the problem?:frowning:

Thank you~~

i am not sure where you got the 1-1200 from… i didn’t check the manual.

This is wrong. 1 equals 2400baud, so you set your radio to 2400baud with the command BD1.
In order to set 1200baud it needs to be a 0, so BD0 will end up setting 1200baud.

I tried it and it works.


Hello raoulvb,

Thank you for your help,you are right,1200baud should be a 0,it works now,thank you very much.

but i have new problem now.i have 3 questions.

My first question…i have tried all of the baud rate(0-1200,1-2400,2-4800,3-9600,4-19200,5-38400,6-57600,7-115200).from 0 to 6 exist no problem…but with 7-115200,it doesnt work.i show you the pics.a bit odd.where ist the problem?(pic1 pic2 pic3)

My second question…in PC Settings Tab exist a baud rate 230400,how can i set this value?(pic4)

My third question…can i set an any value as baud rate?for example 360000.if it can,then how should i set it?

i am working now a programm with that,i want to try every thing exactly.

Thank you~~~^^