Anywhere usb 14 - Configure with RealPort driver (dgrp) on Linux


I’m trying to get my Linux machine work with Anywhere USB 14 Plus. So far, I tried:

  1. AnywhereUSB Manager the way it is described in How to run AnywhereUSB Manager on Linux host without GUI article. Unfortunately, device does not seem to run latest firmware version as it does not work with Client ID or certificates, nor does it have 18574 port opened. I’ve no control over what’s installed on it as it is part of company infrastructure and not used by me exclusively.

  2. RealPort driver (dgrp). I managed to build and install it and this guide was a lot of help, but now I’m struggling to understand whether I can configure device with it. When I run daemon with rp as RealPortID and 771 port, only one tty device appears to be allocated (I expected 14):

    $ ll /dev/ttyrp*
    lrwxrwxrwx 1 root root 13 Apr 26 21:36 /dev/ttyrp00 -> tty_dgrp_rp_0

    So I’m starting to think RealPort driver itself is not enough to make things work. In addition to this I do not understand how to specify a port group which the desired port is part of.

I’m aware of The AnywhereUSB Remote Hub Configuration Utility which probably does the thing for my device, but since it is only shipped for Windows, it is not an option for me.

Thanks in advance!