AnywhereUSB/2 - add network adapter

I need to add a dedicated network adapter in a VM machine (network monitoring purpose).
I tried with a Linksys USB1000 adapter (it uses a ASIX AX88178 ) but it doesn’t work.
does exist a network usb adapter already tested ?

Thanks a lot

I’m not familiar with the Linksys USB1000, but looking into the product online, it appears to be a USB-to-Ethernet adapter to provide a PC an Ethernet jack through USB if the PC did not have a NIC card or needed a 2nd NIC. If this is what the product really does, Digi does not manufacture any product that performs that way. We have an Ethernet-to-USB product called the AnywhereUSB, but the purpose of that product is to provide your PC with USB ports across the network, not provide you an Ethernet adapter that plugs into your USB port.

I’m using Anywhere USB and it works great.
So I suppose this device could also help my to add one more network in a VM Machine.
I’ know my architecture is a little bit strange and unusfull !
The system seems to not be able to load usb driver.
Do you think a new firmware could solve this problem ?


Although we haven’t tested using a USB network adapter (such as that Linksys device) with an AnywhereUSB, it might work. I should note though that the device may not perform as well as expected, because the AnywhereUSB is a USB 1.1 hub, and USB network adapters are usually USB 2.0. Still, I would expect that the device should install at least.

Have you tried using other drivers for the Linksys device? What is the exact error message when you try to install it?

No, I don’t think that different firmware would help, but still, please give me the firmware version of the AnywhereUSB (look on the right side of the config util) and the AnywhereUSB driver version (click View / Driver Information in the config util and note the version of awusbsys.sys).