ATHP reading fine in XCTU but not from application

Any time I attempt to call get_atcmd_value(“HP”) from my programmable XBee S3B-900HP, the command_dump frame handler will get triggered, but it will only echo back the command it is responding to and not the value of the parameter requested.

if (rtc_timeout_expired() && at_response_status == RESPONSE_NOT_UPDATED) {
errcode = get_remote_atcmd_value(“HP”); // Get local radio preamble

I can always get the command replied:
response->command.str[0], response->command.str[1]

…but I can never seem to get anything in response->value_length… It is always 0.

This product is a XBP9B-DMSTB-002.


Are you able to query any other AT command via the processor?

I have solved one problem but 1 still remains. I can now read the HP value (0x02) from the radio, and it is accurate. This problem was resolved when I started using the value found in response->bytes rather than response->value.

I still cannot write a new HP value of 0x01 to the register. I have attempted this in two ways:
1.) set_atcmd_value(), which returns Bad Parameter errors each time. HP remains = 0x02.
2.) Using xbee_cmd_simple() or xbee_cmd_execute() in various ways. I have tried writing HP and I’ve tried writing HP, then AC, then WR using these functions. None of them produce any errors (0) but when I re-read the preamble value, HP remains = 0x02.

I have submitted pictures and code to Case #511337 if that helps. To answer your question about other AT commands: yes. I have successfully read SL and it is accurate. (0x41BC9C11)