Bind/Unbind Requests don't passthrough to the UART

Hi all,

I’m trying to develop an HA compliant device using the Digi XBee ZigBee modules.
The XBee modules aren’t the best way to go, but for some compatibility reasons there’s no other option.

So, I wrote a big part of the ZCL as well as some ZDO blocks. Most of these were tested and approved, I only had to test bindings. For handling bindings I developed a binding table and made the coordinator able to handle End Device Bind Requests.

But when I was testing no message about binding was passed out the UART. The stack just replys with “Not Supported”. Hey! that’s not what I want. I want to handle the End Dev Bind Reqs myself.
I’ve configured the API options (AO) to 0x03, so ZDO messages should passthrough to the UART. Other ZDO messages such as Active EndPoint Request or Simple Descriptor Request are sent out the UART.

Why are binding messages not sent out the UART but simple ignored? I’ve tried AO=0x01, but this makes things only worse. Even an Active EndPoint Request won’t passthrough that way.

Can someone tell me were the hidden option is to enable this messages? Did someone succeeded in passing this binding messages to the UART? Maybe I’m doing something wrong…

Thanks in advance for your response!



No one who has experience with these ZDO binding messages?


I’m having the same issue with ZDO command Match_Desc_req. Have you been able to receive one of those sent from any other node? Have you been able to receive any commands at all for profile = 0 (ZDO). I’ve tried with AO=1 and AO=3, without success. Messages sent to any other cluster (i.e. not zero) are passed out the UART normally in a regular 0x91 frame.


I asked around - seems that is the only message which the current XBee firmware doesn’t allow through. I don’t know why. Someone indicated it was roadmap item, but no idea when that would actually show up in released firmware.

Oké lynnl.
Thanks for your response! That’s some useful information.