Bricked/Frozen Xbee S2 -- I think that bootloader is corrupted. Any way to reinstall bootloader to xbee s2

I have tried all the methods available on the internet. but still can’t find a solution.

I have two xbee s2. I programmed one of them as coordinator(API), and the other one as router(AT). But after some time when I tried to read the router xbee s2, it will give me a popup info box telling me to reset the xbee. I tried resetting it by shorting reset to ground but nothing happens. I then followed some instructables but still wasn’t able to revive my bricked xbee s2.

The coordinator (API) xbee s2 seems to be working fine.

I tried entering into the bootloader menu of the bricked xbee s2 but nothing happens when I enter ‘B’ in the terminal window.

I am using Arduino UNO (rev 3) to read and write on xbee s2 because I don’t have an FTDI cable. I do this by shorting out the controller on Arduino UNO.

I don’t think that the UNO is causing problems as the coordinator xbee is working fine.

Any possible solutions???

I have tried the following solutions…


I would like to know how to re-install bootloader to xbee s2, or if you have any other possible solutions, let me know.

If you require more info, let me know.

I believe the bootloader is locked. If it’s not working you’ll need to RMA the module.