Can not Enter Bootlaoder XBee S2 Modul

Hello together

I am using a Xbee S2, and its bricked.

I try enter the Bootloader with the the xbee exlorere Board
like its shown at the guidlines restore the boards
but the problem is after reseting the Xbee its sending back “.” over the terminal but its not enterering the bootloader if I press captial B.
Its just stuck

How can I solve this, all seems be connected well ?

Thanks raphael

Hallo Raphael,

Are you using a Programmable XBee or a regular S2? If it’s a Programmable try flashing “Serial Bypass” application and let us know if that worked.

If it’s a non-programmable, maybe the problem is in the baudrate, it should be at 115200 to see the Ember’s Bootloader. Anyway, if you are receiving “.” and want to flash the radio, do it from “Modem Configuration” tab with the “Always update firmware” option checked; it should be able to detect the ember’s bootloader and flash the firmware.

Best regards,


I am using regular S2, I think I bricked by trying uploading the wrong firmware from the list in x-ctu.

What you mean with serial Bypass ?

Thanks for respond I will try

I’m having the same error with one particular module.

The device is not bricked as I am able to read the firmware and settings normally and use AT commands.

However I am unable to enter the bootloader menu, and therefore unable update the firmware.

The module is an XBee S2

Modem: XB24-B
Version: 1247

Hardware Setup:
VCC is 3.3v
GND is 0v
RTS is 3.3v
DTR is 0v

DIN is connected to a dual pole switch
Pole 1 is tied to ground
Pole 2 is tied to TX of a serial adapter

Serial Configuration in X-CTU:
Baud: 115200
Data Bits: 8
Stop Bits: 1
Parity: none
Flow Control: none


  1. I click on the terminal tab in X-CTU

  2. I switch power to the XBee off

  3. I switch the dual pole switch connected to DIN to ground

  4. I switch power to the XBee on

*. At this point I receive a ‘.’ character in the terminal, which according to documentation shouldn’t happen

  1. I switch the dual pole switch attached to DTR to TX of my serial adapter

  2. I transmit a lone carriage return

*A DIGI wiki document somewhere says instead to transmit ‘B’ then a carriage return, both have worked for me normally on another module, neither work for this particular module.

I know this setup and process would normally work because,
I am able to plug another XBee S2 directly into this same setup and process and can successfully start the bootloader, and update the firmware.

Here is this other modules configuration:
Modem: XB24-ZB
Version: 20A7

I’ve spent far too much time on this at this point and am getting aggravated especially with my inability to determine what is what in the entire XBee product line.

I could care less if the thing ever works at this point,
But I would at least appreciate a detailed low level explanation at to why I can’t get to the bootloader.

Thanks [:)]

Its may possibel upload the *.hex File of the firmware by hand for example with another terminal programm ?.

The problem is that we can’t get to the bootloader menu.

There are commands to manually feed a firmware through a terminal but they can’t be used because of the inability to get into the bootloader.

I don’t suspect the terminal as an issue, but it could be worth a try.

Dear grit

For shure !

what kind of file i can be use fro try out with hex, this *.ehex files ?

Ihave two S2 Board



XB24-BWIT-004 revE0013A200408A5FC6

Hey soem IDeas how i can solve my problem ? , now its time continus my project !!!. Hey Digi people its possibel uplaod the hex file may with other seriall programm ?

Hello Raph,

When XCTU fails on reading module it pop-ups a message asking you to reset your module. Did you try that?

If you receive ‘.’, try with 38400 bps. However, XCTU should be able to detect that your module is already in bypass mode in the Modem Configuration tab if you press “Write” with “Always Update Firmware” Checked (and the correct firmware set selected).

yeah …dont work… I tried many times its not working I also tried put /in out USB connector…the pop up message never disapears

after reset Xbee its sending “.” well the pop up window any way dont disapear

Hello fgilmar
after reset the Xbee is sending “.” I can see in the terminal anyway the pop up window dont disapear

thanks Raph