Can Xbee2 module be recoevered w/o using a development board

Now i have tried every possible method enlisted on the forum to recover the XBEE- S2 module with antenna.
Probably the failure is due to a failed write cycle.
( I don’t have a development board)

I have tried following things till now…

  1. Configured X-CTU in all possible combination’s of Serial Port setting.
  2. Checked it in AT command mode/API mode.
  3. via packeting the data using terminal.(cmd send : +++)
  4. Modem Configuratuion is UNKOWN- But still i tried to it in XB24-B Zigbee configuration hoping for the software to hook to the device.
  5. Checked for boot loader but no response there too.

I think there is no hardware problem with module as,when i power the working module.

Dots are displayed on the terminal and the Dead Xbee module also shows the same display on terminal when powered.
Error from the dead module is :

Failed to enter command mode
Unable to read Version (ATVR)
Detected baud rate difference.
Make sure PC and modem baud rate is set correctly
Read parameters…Failed.

I had two of them one of them is working fine, but i don’t have any zigbee devices at home so that i can create a network.Nor do i have a development board.

Please help,Thanks.

You don’t need to have a development board: you just need to make sure your circuit incorporates VCC, GND, DIN, DOUT, RTS and CTS - with voltage level converters if you’re connecting to anything other than a 3.3V host.

Question 6 of the FAQ gives a little more detail on this.

I successfully started the boot loader after reading Section
8.1.3. XBee Series 2 Custom Bootloader in the module datasheet.

Once the boot loader starts , I select the first option to upload the ebl file.But the boot loader stops in the mid and following message is displayed.

.EM250 Bootloader. v20 b09
.1. upload ebl
.2. run
.3. ebl info
.BL > .11
.begin upload
.Serial upload aborted


Right - that’s my level of knowledge exhausted :frowning:

Can anyone else chime in here?

Hi John,
Thanks for your help.

“I hope to get a reply from community manager or support person,kindly look into this matter.”


when you get cccccc on the x-ctu, which shows that you need to upload .ebl firmware file now. You need to upload through x modem option at the top within the time out period for uploading .ebl file which is shown by ccccccc in the terminal tab

Do i have to select .ebl from a location in my computer ?
and are there any documents on how to achieve this ?


ebl files are stored in the local pc program files\digi\xctu\ and .ebl files are named as modem type +firmware version. ebl

I was busy making PCB for Xbee.Just received it and wired it.
But still not able to upload a file using xmodem protocol in Xbee.

The connections i have used are:

DTR - Low
RTS - High

Rest of the Schematics as mentioned in Xbee shield schematic circuit from Arduino.I have attached a file.

You need to upload through x modem option at the top within the time out period for uploading .ebl file which is shown by ccccccc in the terminal tab

I selected the .ebl file to load and used send file feature of Hyper Terminal to send using Xmodem.The number of retires increases and finally it shows the “Communication not possible message”.

I have checked that Xmodem protocol does not uses RTS, CTS or DTR lines of com port. So I am not getting what else could be the problem.

A correction in the circuit schematic given above…

It is must to level covert the DTR pin using a pair of transistor and resistance…