BSOD and DeviceFailedEnumeration

I just purchased an AnywhereUSB/2, to which I’ve connected a 7-port hub (D-Link DUB-H7), to which in turn I’ve connected 3 Prolific USB-to-Serial interfaces, 3 US Digital QSB devices (which appear to be based on a Future Technology USB-to-Serial interface), and an Agilent 34972A data logger. I’m currently using a desktop running Windows 7 64-bit, but I’ll also be using this setup with a laptop running Windows 7 32-bit (which I haven’t had a chance to try yet).

All work fine when the D-Link hub is connected directly to my system. Also, I’ve confirmed with the awusbcheck.exe utility that all are compatible with the AnywhereUSB.

First issue:

When I first started trying the AnywhereUSB/2 yesterday, the 3 Prolific USB-to-Serial interfaces were connected to the hub, but nothing else was. When I hot-plugged in a US Digital QSB, my system immediately blue-screened with:

0x1000007e (0xffffffffc0000005, 0xfffff80002c98584, 0xfffff88003531f98, 0xfffff880035317f0)

From opening the minidump in WinDbg, WinDbg says the BSOD was probably caused by ftdibus.sys, which is the driver for the Future Technology USB-to-Serial interface. So not necessarily the fault of the AnywhereUSB, however this has never happened before without the AnywhereUSB. In the past day, it hasn’t happened again, either, with the AnywhereUSB, but I’ve just been leaving the QSB plugged in all the time. (I’ve been testing with only one of them so far.)

However, the connection to the QSB through the AnywhereUSB seems a little flaky. Sometimes it fully loads up and works fine; sometimes it doesn’t. Currently, it’s recognized in Device Manager, but no COM port has been assigned. The Device Status says, “No drivers are installed for this device.” The AnywhereUSB Viewer Utility is showing a yellow exclamation point icon for the QSB.

Second issue:

I can’t connect to the Agilent data logger through the AnywhereUSB at all. Device Manager shows “Unknown Device,” and the AnywhereUSB Viewer Utility shows “DeviceFailedEnumeration.” All fields in the Device Descriptor are zero.

I’ve tried rebooting the AnywhereUSB, the data logger, using the “Use Microsoft Device IDs” option, etc. Nothing has any effect.

I saw mention of a beta driver for the AnywhereUSB in another thread, but it appears to be 32-bit only. Is there a beta driver available for Windows 7 x64 that might solve these problems?


Here’s the 64-bit version of the latest beta AnywhereUSB driver:


Try it out and let me know if it helps with any of the issues. First, uninstall the existing AWUSB driver by clicking View / Driver Information / Uninstall, and reboot the host PC when prompted. Then install the newer version after Windows loads.

Just installed and tried the beta driver. Unfortunately, no change.

Still getting “Unknown Device” / DeviceFailedEnumeration for the Agilent data logger and “No drivers are installed for this device” / yellow exclamation point for the US Digitital QSB. (Strangely, the latter problem appears to be fairly consistent now, whereas it was occasionally working before.)

Is it safe to assume that you tried the “Use Microsoft Device IDs” option again? I’m not certain if it makes a difference, but the way I usually suggest making that change is as follows, so try it that way if you haven’t already:

  1. Enable that option then click Save.
  2. Disconnect from the AWUSB.
  3. Connect to the AWUSB.

Just tried that … no change.

I also upgraded the driver and firmware in the QSB, and now that’s working again, so good news there, but the Agilent data logger still isn’t working.

I also tried connecting the data logger directly up to AnywhereUSB (rather than going through the D-Link hub). No change.

Is there some way I can send you some debugging information that might be of use to you? I see an option for “Enable driver event logging,” but I’m not sure what kinds of information is logged (or where).

Yes, we should get a trace to continue troubleshooting.

Please open a support case with us:

Reference your thread, #9059, and I’ll reply with instructions for getting a trace. It will be best to communicate directly with me through that channel from here on out.

Update device with newer firmware and drivers