AnywhereUSB - Blue Screen after plugging in Bluetooth device


A device we plug into the AnywhereUSB causes the host to blue screen.


OS: Windows XP SP3
Hardware: VMware ESX virtual host (IBM HS21 8853L6G)
AnywhereUSB drivers: 40002670_D
Device: Generic Bluetooth Radio (USB\VID_0A12&PID_0001&REV_1958)


The AnywhereUSB is detected correctly by the host and works when an external USB storage was plugged in for testing.

When the Bluetooth device is plugged into the AnywhereUSB device, the new hardware wizard appears and then if we continue with detecting the device automatically the host blue screens.

We tried to use driver “ftp://austin:!15st3n!” and still get a blue screen.

Many thanks

What does the blue screen say? Are there any files referenced, for example, a “.sys” file?

Please see attachment

Message was edited by: alexor

Please see attachment

Download and then run the AnywhreUSB Check Utility on a separate physical PC and let me know if it passes (compatible) or not (incompatible).

The Bluetooth device will need to be attached directly to that PC (not the AnywhereUSB).

Please see the log below:

[i]1 USB device found.

Incompatible devices found:

Generic Bluetooth Radio VID = 0x0A12 PID = 0x0001

No compatible devices found.[/i]

Is it mean that this device will not work with AnywhreUSB?

USB devices that use the “isochronous” USB transfer type are incompatible with the AnywhereUSB. The Check Utility that I had you run simply checks to see if attached USB devices are isochronous or not. Your Bluetooth device apparently is isochronous, so that’s why it’s reporting as being incompatible. There’s nothing we can do to make these kinds of devices work with the AnywhereUSB. I suggest trying to use a different kind of Bluetooth device that uses a different transfer type such as Bulk, Control, or Interrupt.