Can I have my XBee back, please?

[bgcolor=orange]Please ignore this post. Answer below is correct. The module is S2 ZigBee that had been put into S1 packaging with a label indicating S1. Sorry to waste the space and anyone’s time reading & responding.[/bgcolor] :

XB24-Z7WIT-004 Rev K

I successfully wrote the XB24-ZB firmware to the module. Therein lies the problem since it is a standard XBee Series One module. Total brain fade after working with some S2 modules.

I am able to get the bootloader screen so an operable bootloader is present (.EM250 Bootloader. V20 b09). However, trying to write the 802.15.4 firmware to the module through recovery or writing new firmware results in an error (Programming modem…Flash checksum error failed). It would appear that the bootloader associated with the XB24-ZB firmware is not compatible with the XBee firmware for re-writing. I have tried other firmwares in the hope (wishful thinking), that a firmware would create an intermediate bridge back to XBee.

One module is presently configured as a Zigbee coordinator AT (CD) and the other is an end device AT (ED). While they do communicate it is very unreliable from the ED side. Using XCTU console with two modems, the ED transmits packets but it is hit or miss for several transmissions as to whether the CD receives the test message. However, when communication is initiated by the CD, the ED transmitted packets display in whole on the CD console. Leaving the device alone for a minute or two results in the same ED transmission problem. Its as if the ED needs to be woken to establish a comm handshake. If there was not the comm problem, I would just live with the Zigbee firmware.

I have tried the standard module firmware recovery method to no avail. Also tried writing the .edl file through the bootloader screen.

Is there another method of recovery?

The part number of the module you listed is NOT an 802.15.4 module (XBP24-Axxx or XBP24-Axxx) but an XBee ZB module for which it has the correct firwmare version installed on it.

1 Like