Slowbie Newbie

I’ve just used x-ctu to install firmware to some xbee modules. Tried to get one module (an XB24 to be zigbee coordinator AT, version 8013 software.

The problem is this

  1. new module, ‘PC Settings’ tab, ‘Test’ button, new module responds appropriately confirming good comms.

  2. Select XB24 Zigbee Coord, 8013 firmware and download.
    Sequnce is initialising…programming…but then it falls over at AT setup ‘Failed to enter command mode’

I get one good download but then every time after that it seems impossible to reconnect with the module via RS232. So I’m guessing that somehow I am changing the port settings, but I don’t actually change anything from the default setting.

This has happened on three modules with total accuracy and I’m loathed to buy more modules now for obvious reasons. I want to sort this out and learn what my mistake could be !

Any help appreciated

Please answer a few questions about your modules/setup.

  1. Do you have the series 1 Xbee or Series 2. I am assuming series 1 since you posted under the 802.15.4

  2. Is 8013 the firmware version? I do not have the beta versions anymore for the Xbee to check what the firmware versions were.

  3. If you are using the series 1 Xbee how important is a mesh network to your system? If a mesh is needed, do not use the beta version of zigbee mesh that was released for the series 1 unless you have a simple network.

  4. Have you checked the “always update firmware” checkbox in the modem configuration tab of X-CTU to reload the firmware?

I’m new to these particular models, forgive the lack of knowledge !

Chip modules are labelled XB24-ACI-001-RevB

001 = series 1 perhaps ?

PCBs ‘REV2 PN 30009xx2-01,2007 Maxstream’
Again, there’s an ‘01’ in there

8013 is the firmware version. Perhaps this post has gone into the wrong forum, because I am looking to set it up for zigbee, however, is there enough of a difference when using x-ctu for 802.15.4 ?

A mesh isn’t important, but multipoint access is important to me. I want to be able to introduce equipment int a wireless zone so most of the units will be (presuming from documentation) routers.

If I shouldn’t use the beta versions, which vesions should I use instead of ? I am using 'always update firmware, and performed a check for updates before beginning.

Thanks for the help

From the model number you are using the series 1 with the chip antenna. From what you are saying, some of the modules will be out of range and you are needing routers to get the data to your collection point? If so, you will need to use mesh, if not then 802.15.4 will work. Lets do the following if 802.15.4 will work:

  1. Download the latest firmware from digi within XCTU. Go to the modem configuration tab and click “Download new version” then click “Web”.

  2. After the download, within the modem configuration tab, select the Xbee 802.15.4 function set and version 10E2.

  3. Try writing the firmware to the module. If you are still having problems try holding the reset button on the PCB then click “write” again. After you click “write” keep holding the reset button for 1 second. This should do the trick.

Thanks for the pointers.

Am I understanding you correctly that Zigbee won’t work with these modules ? I’m hoping it’s just a change of configuration that’s required.

I’ve tried your advice but things are no further improved.

This is the kit I bought

And this is the pdf 4 page instruction. I followed the instructionsat the top of page 3, to select ‘coordinator AT’

I’ve attached a picture of the x-ctu options which I have. Notably the software version you suggested I use doesn’t appear in the list, despite performing several web updates.

      • Update * * *

I’ve tracked down a document by Digi stating that Rev B modules are NOT compatible with Zigbee and should not be used. The vendor which sold me the dev kit has got it listed as a Zigbee/802.15.4 kit.
I have written to them to point out the misrepresentation and have suggested that 1 solution for m would be if they replace the three XBee series 1 modules with three series 2 Znet 2.5 modules from stock. Otherwise I will need a full refund.

And I thought I was being a slow learner…hopefully my next message will be on the Znet/Zigbee forum instead !

Thanks for the help,

Thanks for including the picture. The zigbee firmware was first introduced with the series 1 modules but the series 1 did not have enough memory to handle zigbee, thus zigbee is no longer available for the series 1. My mind also slipped up on the previous replies, the series 1 has the ability to use mesh. Digi has released thier own mesh called digimesh. Digimesh has the ability to sleep all nodes. You can try loading on that firmware. Under the modem drop down box under the modem configuration tab look for XB-24DM.

Forgot to add something else to try.

  1. go into the terminal tab of XCTU. do not type anything for at least one second then type +++ and do not type anything else for at least one second. The module should repy with “OK”. If it does type ATRE and press enter. The module will respond with “OK”. This will restore the module to default parameters. Then type ATWR and press enter to save the parameters to memory. The module will respond with “OK”. Then type ATCN to exit command mode. Try loading on the firmware you want and see if it will load.