Can't revert from ZigBee 4043 firmware


I wanted to try XB24C’s ZigBee 4043 firmware on my programmable XBee S2C ZB module. After flashing the firmware, the XCTU (v6.3.10) tells it cannot find a firmware for the selected device, and it cannot display any configuration information. This is written in Function description at the radio modules tab: 4043 - Not found in XCTU.

I tried to recover it with XB24C’s ZIGBEE TH Reg 4060 firmware, but the process didn’t halt although I reset the module.

I am able to communicate with the device in transparent mode. I set it to API mode now.

Is there any way to flash one of the other firmwares on my device?

Thanks in advance.

What is the full part number for the XBee module you are working with?

The part number of the device is XB24CZ7WITB003, and I am using Sparkfun XBee Explorer dongle to communicate with it. I tried the XBIB-U-Dev board as well, but nothing changed. Something may be went wrong during flashing the firmware.

If you are running any applications on the Freescale processor other than the bootloader, then yes you may have lost connection to it. This is because the freescale processor wants to talk to the RF processor via API mode. When you load a new application on the RF processor, you need to have API enabled otherwise the Freescale processors code as no idea how to talk to it.