Firmware update failed, now bricked??

I have a Xbee Pro programmable s2b on a adafruit xbee adapter and a FTDI cable. I needed to change the function set from router to coordinator for the network to function properly. The firmware didn’t take properly, and it refuses to take a firmware upload again.

I tried holding the reset while power up trick, but that doesn’t work because on reset, it defaults to API mode, which does not allow the command mode to be accessed. Is there anything I can try? Any ideas are greatly apprecaited.

Don’t give up hope yet!

Over on the 802.15.4 forum, you’ll find a couple of pinned posts at the top. Seek out my FAQ, and look there for suggestions as to how to recover from this situation. Although the FAQ is notionally for 802.15.4 modules, I think the firmware upgrade parts are pretty universal.

If you try those suggestions and it still doesn’t work, then contact the excellent folks at Digi support and mention this thread.

If one of the suggestions does work, or if they lead you to finding a new recipe that does work, please post the details so that I can add the solution to the FAQ.

I haven’t had any success yet, but I will keep trying.

For future projects, I don’t need the programmable xbees, but I stilll want to use the higher power modules. I can’t figure out the difference between the

XBP24BZ7WIT-004 Zigbee ZB Pro


XB24-AWI-001 XbeePRO OEM

What I am looking for is simple point to point communication. Input is appreciated. Thanks