Can't connect the development board on the network.


I tried to create a network which has a Wi-i.Mx51 development board, a laptop and a wireless router via both cable and wireless.

I set up the IP address(dynamic) on both wire and wireless of the DIGI board following the instruction. Both got the right IP addresses which running after the laptop IP address, but I can’t ping the router from the DIGI board. When I checked on the router set up page, I can see the DIGI board mac address connected to it, but not the wireless.

If I just connect my laptop and DIGI board to the main company server via cable, they (DIGI board and laptop) were connected. I also tried with the static address, it did not work.

In any condition the wireless on DIGI board has never been connected. I have not security on the router at all. I use 802.11 b/g router.

I am not sure what else need to be done to be able to connect the DIGI board onto the network.

What is the IP address of the router (local)?
What is the IP address, subnet mask, and gateway of the Digi board?
What is the IP/subnet/gateway of the laptop?

The router is LinkSys WRT54GL and its IP address is

Laptop IP address is, net mask is, gateways is

DIGI IP address is, net mask is It dis not show gateway address when I commanded “ifconfig”, but I set the serverip as on the DIGI board.

The gateway in Uboot is gatewayip.

From Uboot, if you set DHCP on:
setenv dhcp on

And then do a ping of your router and laptop:

Does that work?

I set gateway ip.
I set dhcp on.

No, it still doesn’t work with some reason.

The only difference between the company main network and my local network is the company network can access to the internet, while my local network can not. I would not think that it is related.

can you post the output of printenv and printenv_dynamic in uboot prompt?

I have a similar problem. Configured as outlined below:

ConnectCoreWi imx53

dhcp setenv off
setenv dhcp_wlan off

setenv ipaddr (target)
setenv netmask
setenv serverip (my PC)
setenv gateway (my router)
setenv GatewayIP (my router)

I “ping” from the PC to the target and no response.

Ping wont work until and unless you start OS. Default uboot on Digi wont respond to ping, as TCP/IP stack is not initialized.

Make sure that is not used by any other device on network. ie: a ping to that IP should not work until and unless you boot OS on Digi module.