Can't find Xbee in XCTU

I have the Xbee 3 inserted on an XBIB-C board. One thing I notice that is different from my other modules is that the UART DOUT LED is turned on. When I try to discover the module in XCTU I get the following message “Could not find any device in port COM3 > Error initializing Xbee device parameters > Port is already in use by other applications”. What I think is the problem is that I have a micropython program running with a print command in a while loop (no time.sleeps()), which is why the UART DOUT LED is constantly ON. Since I seem to not be able to connect to the xbee what can I do?

I’m going through something similar to what you are. As my project became more complex I came across this problem within my While (True). I tried using the XCTU option - XBee Recovery. Since then I started using the “break” command
RECOVERY

Xbee recovery does not work, I get the same error message.
Thanks anyway :slight_smile:

Moon, The Error of “Port already open” means that you have an Application running on your PC that is already accessing COM 3. You will need to close out of any application that is currently running before XCTU will be able to talk to the COM port and talk to the module connected to that COM port.

I wondered about this possibility, but this happens regardless of the computer I use. The code I am running on the Xbee utilizes the Primary UART for serial communication. I am starting to wonder if that is causing the issue. What would be my next move if that is the case. I have tried to send it AT commands from another xbee to factory reset, but all that does is freeze it (All the LED lights turn on) until I press the reset button and it goes back to the same mode as before. I can connect to it using another XBEE on the same network so its not dead,

I would suggest sending the remote AT command to disable Python from running on start up and disable Python mode.

Which command is that?

That would be the PS command (Python Auto start) and AP0 (Transparent mode).

I have done so. I notice a difference in that now the conn status LED is blinking a lot faster. I tried finding it again in xctu to no avail. Then I tried to recover it in xctu and got the “There is no active bootloader in the module”