Changes between original and -S modules


Having an application that ran with the original module, I tried to run it with the -S type module but with no success.

Below is what I did:
1- Re-installed NET+OS6.0B, P/N: 40001928_B November 2003, build
2- Replaced MII.c file in ‘platforms/connectme’ with the one contained in ‘’ provided by Digi support.
3- Rebuilt the BSP and the application with command ‘make PLATFORM=connectme’.
4- TFTP ‘image.bin’ file on the -S module and restart it.

At this step, in normal condition, the applcation should start and start ftp and http servers.

But it seems not to happen as expected, because neither ftp nor http server is running.

I tried to connect to ftp or http (the application includes web pages) servers but I did not succeed as it return ‘unknown code error’ message.

I was told the only things to do to make it run with -S module were the steps explained above.

Is there any other parameters to change (memory start address or anything else …)?

Thank you