Changing baud rate on COM ports of Etherlite 32.


I am unable to find a way how to change baud rates on COM ports. I have installed RealPort driver on WIndows 2003 Server. Under device manager>properties it shows that the “Multi-port serial adapter” is connected and if I “rlogin” to the device it shows “Established” connection from the Win.2003Server. I did chnage the baud rate for all ports to 115200 but it di not change the rates on the device. If i run “line” while rlogin it shows baud rate 9600.
The web browser does not connect to the device either, I do not get how would it if the device is not listenin on port 80, specifying default port 771 in the browser poduces following output:
“ÿAccess to unopened portG”

The way the RealPort driver works is that it will automatically open the ports at what ever baud rate you tell the ports to open to. For example, if I were to use HyperTerminal as my application and I tell it to use 19200 8N1 with no flow control, RealPort will open the port at that speed automatically.

Regarding the web browser issue, the EtherLite does not have a web interface like the PortServer TS product line would. It only has the option to rlogin for information purposes.

Thank you for the information in regards the web support. How can I possibly set the baud rate on the telnet session? As I understand in order to connect to a terminal session one need to telnet to the IP of the machine (where the RealPort driver is installed) to port 2000 + port number. For example if I want to connect to port 2 I will have to type something like:

telnet 2002

The Etherlite doesn’t have a built-in telnet server either, it only supports rlogin. The type of telnet operation you mention would be supported on the Portserver TS line of products.

The Etherlite ONLY works with the Realport driver, not http, telnet, or SSH.

So, it sounds like it should be more simple to connect than I thouht.I have tried to connect to a COM port that is connected to a device I need to access via console but it never was able to establish the connection. In rlogin session I can see my IP that has established the connection to Etherlite on port 771. The machine where the RealPort driver installed connected to the Etherlite using Cisco switch Catalyst2950.

I wonder if you are running into a cabling issue, causing you not to be able to talk to the end device. Have you tried to run a loopback test to the port with the loopback plug? If the device passes the loopback test, the port should be functional. I would say that it is most likely a cabling issue at that point. I have provided a link to the pinout of the EtherLite below:

This device does not have the same pinout as the PortServers, so if you are using the same cabling as you would for those devices, it will not work.

Hi zachh,
I would like to thank you and admin for your help. According to the manual 90000630_D.pdf the “loopback test is not available for EtherLite or Digi CM devices”.
Any way atried to match the RJ45 pinouts to Kontron blade as follows:
Etherlite Kontron
1(RTS) 8(CTS)
2(DSR) 2(DTR)
3(DCD) 5(Ground) - this is questinable there are 2 GRND
4(RxD) 3(TxD)
5(TxD) 6(RxD)
6(Ground) 4(Ground)
7(DTR) 7(DSR)
8(CTS) 1(RTS)

I was using EIA-232 DTE Pinouts diagram in 90033900d.pdf and connector pinouts for J14-RS-232 of AT8020 Quick Reference.pdf (both attached.