Communication error

While compiling a programm, Dynamic C display the error massage “Communication error” after the action shown below.

No, I haven’t solve the problem yet.

Today, I wrotte a E-Mail to the Rabbit Support.

You got the com port selected, got the programming cable plugged in correctly ?


im ajeerah…i am the new user for rabbit…i also got the same problem as RabbitBeginner… after i run the programming…the message ‘while sending pilot BIOS: target communication error’ pop up… all the solution that mention before on this forum or others forum i already try and still the problem not solved…please anyone do help me…

Hi all,

Did you finally program it?
I have the same problem with my rcm5650w…

All the connections are ok…

We are desperate!

Hello, Which operating system and Dynamic C are you using?
make sure that Enable USB to Serial converter options under Project options.See that attachment

I am using Dynamic C 10.60 and set all the options as shown in screenshot, but still i am getting error pop-up as “'while sending pilot BIOS: target communication error”.

Please help me.

  1. Unplug the USB to RS-232 converter cable from the PC or laptop USB port.
  2. Download FTDI’s driver installer program at
  3. Run the CDM20828_Setup.exe (or later) installer program that you just downloaded. Remember to exit the installer when it is done.
  4. Plug the USB to RS-232 converter cable back into the PC or laptop USB port.
  5. Now compile and run the program.