How can I correct a communication error in Dynamic C 9.62


I recently installed Dynamic C ver. 9.62 on a PC running windows 8.1 64 bit. When I try to compile a program I get an error message that says “while sending pilot BIOS: Target communication error”.

How can I correct this?

Thank you,


We have not tested Dynamic C on a Windows 8 machine, however, this may work.
If you are using the USB cable, there may be an issue with the latency timer on your pc port.

you might want to adjust the latency timer on the port you are using:

If you are having communications issue, you may need to adjust the latency timer on your port: (if you are using the USB programming cable)

There is really slow performance on some test fixture’s FTDI USB-to-serial COM ports, we discovered that in the USB COM port’s “Advanced Settings” dialog box there is a “Latency Timer (msec)” selection drop-list. We found that reducing the latency setting from the (apparent) default of 16 msec to a much smaller value (1) resulted in much better performance.

Set 1 msec latency on the COM port I used with DC 9.62. I haven’t had a DC 9.62 target communication error on that COM port since.

The FTDI USB-to-serial COM port “Advanced Settings” dialog box looks like this on my PC:

Notice in the “BM Options” area the “Latency Timer” selection drop-list.

I think the latency setting of 1 msec might be using up more CPU and / or USB bandwidth than necessary, so it might be best to experiment a little and use the highest latency setting that doesn’t cause frequent TC errors.

Please let me know your results.


you can check the the module on a PC running windows 7 or XP system, if that error also, it maybe the some issues with the module or programing cable.
you can use other modules to compile a program, if that error,we are sure the issue not with the PC system and Dynamic C 9.62.
as my experience, this error prompts that some issues with the module.


Thank you.

I changed the port latency to 1 msec as suggested and the problem is resolved.

1 Like

I am glad your issue has been resolved by changing the latency timer on your port! :slight_smile:

I was able to adjust my latency to 13 msec. 14 and greater did not work on my machine, using the USB programming cable, 20-101-1201.