Windows 8 communication error


Working on an old program with Dynamic C 9.62, but on a new PC (64-bit Windows 8) for the first time, with fresh download of the EasySync drivers from their site.

Cannot compile to the target: get Target communication error.

  • several different targets (RCM2200/2300)
  • several different programming cables (which have worked before)
  • several USB-RS232 adapters (EasySync) which have worked before.

Environment options should be OK (use USB adapter, etc).

Help! What can I try next? Is this a Win8 problem?




Everything works fine on another PC (Windows XP).

If you are using the USB cable, there may be an issue with the latency timer on your pc port.

you might want to adjust the latency timer on the port you are using.

If you are having communications issue, you may need to adjust the latency timer on your port: (if you are using the USB programming cable)

There is really slow performance on some test fixture’s FTDI USB-to-serial COM ports, we discovered that in the USB COM port’s “Advanced Settings” dialog box there is a “Latency Timer (msec)” selection drop-list. We found that reducing the latency setting from the (apparent) default of 16 msec to a much smaller value (1) resulted in much better performance.

Set 1 msec latency on the COM port I used with DC 9.62. I haven’t had a DC 9.62 target communication error on that COM port since.

The FTDI USB-to-serial COM port “Advanced Settings” dialog box looks like this on my PC:

Notice in the “BM Options” area the “Latency Timer” selection drop-list.

I think the latency setting of 1 msec might be using up more CPU and / or USB bandwidth than necessary, so it might be best to experiment a little and use the highest latency setting that doesn’t cause frequent TC errors.
This works with Windows 7, and may work with Windows8