"Loading initial loader" and hangs on Windows 7

I just bought RCM5600W and had everything connected and Dynamic C 10.64 installed on Windows 7 operation system. When I tried to compile one of the sample tests TOGGLESWITCH.c, it gives a “Loading initial loader” message and sits there forever.

Do you know what the problem is? Is it because Dynamic C 10.64 doesn’t support Windows 7?


Hi ,

May be because of project settings it was working like that.
Do the needful settings.

Open Dynamic C.
Select Options–> project options, it will open one window .
from here select the serial port(which com port are you using), select check box usb to serial converter.

Then click on targetless tab select the board name 74MHz,RCM5600W . Click on Ok.

Then compile and run the program , it will work.

Dynamic C and Windows 7 have a driver issue. If you install Dynamic C without the hardware attached you may have issues. I suggest that you uninstall Dynamic C, attach the hardware with power applied, then re-install Dynamic C.We also recommend that you do not use USB hubs.


I currently trying to load a sample program to RCM5600W on a Windows 7 OS.

I am current experiencing communication errors despite changing the targetless settings to RCM5600w @ 74Mhz as well as changing my Max download rate to 57600 and debug rate to 2400.

The program is able to load initial loader, sending pilot bios and complies…thereafter the communication error appears.

How kind friends can advice me where / any steps i have missed out? thank you!

Hi ,

Select the minimum debug baud rate 9600.
Then it will work.

Hi cpigilam,

Thank you for your reply. I have adjusted to 9600 for debug but still same error. ={

Try to put normal settings,

Debug baudrate is 115200,select check box Disable Baud Negotiation,select check boxes Enable processor verification, Use USB to serial Converter. Stop bits 1

Good day!

I have set the settings but it shows ‘timeout while waiting for response from target’

Could it be communication error due to driver on window 7 OS…because i tried it on XP and it was error-less…

Did you tried with Run(F9) button?

Yes…done…i actually reinstall the whole program but still get the same error messages

Hi ,
Did you check correct COM port for the 5600?
open sample applciation then click on compile button select
Reset target/compile BIOS.
Can you able to see the BIOS successfully compiled?

I dun think the bios was compiled successfully, this was what happened when i did a reset target/compile bios:

loading initial loader -> sending pilot bios -> error->while sending pilot bios: timeout while waiting for response from target

I have verified that the com port for the 5600 is correct ( @ comport5)

is there a need to update the comport from device manager?

i just did an update, the comport is already up to date…

Try to connect USb to other port, then check .
Check it out USB port connected properly at development board

yup…checked. USB port is connected properly…even when i change to different slots, i am still getting :

loading initial loader -> sending pilot bios -> error->while sending pilot bios: timeout while waiting for response from target

i was looking thru the drivers folder and saw this Rabbit USB Programming cable -> winxp_2k

Could it be this that stops the communication/complilation process?

Try to do the following…
First uninstall the Dynamic C on your system.
Attach your hardware with power applied, then re-install Dynamic C.

Yup it still posts the same error after uninstall and install with the hardware on…during the installation process the comport has been self identified by the setup…

Would here be a driver for win 7 OS?

Hi ,
I have checked in Windows 7 (32 bit), Windows 7(64 bit)
It was working fine.
Try to do like this

  1. uninstall the Dynamic C on your system.

  2. Connect the RCM 5600 to the system.(At this time it will install the drivers for RCM5600,select COM port also)

  3. Install the Dynamic C

  4. Run the program.

If it does not work, Check with another module.

Another Imp point is make sure that select Check box for the Use USB to serial converter.