[ConnectPort X2 Gateway] Cannot upload the example.

Hi there,

i got the Drop-in Networking Professional Development Kit ZNet 2.5 (International) found here: http://www.digi.com/products/model.jsp?lid=EN&pgid=127&pfid=144&mtid=2826&amtid=2829

After playing with examples, described in the documentation, i tried to upload the Python example on my ConnectorPort X2 Gateway.

I received an error message, which tells me, that there is no more room for those files.

Does anybody has the same error?


The X2 Gateway has little memory. As such, most of the examples you will find will not fit on it. To verify this, I would recommend checking the available memory option on CPM.

If you’re trying to get the Embedded Kit Gateway Viewer working and getting “error 5 - out of space”, its likely because python.zip is loaded on the unit. python.zip is not required for this application, and can safely be deleted.

Additionally, here is an article which might help:

And a location to get the current python.zip, should you want to load it back on the CP-X2 in future:

Uploading works fine now.

Got this files on the X2:


But after login with telnet, and running the command: python EmbeddedKitService.py

I receive following exception.

Starting up…
Ready for incoming requests!
Discovering nodes…
Exception in thread WPANSerialEndpoint:
Traceback (most recent call last):
File “WEB/python/embedded_kit_gateway.zip/threading.py”, line 442, in __bootstrap
File “WEB/python/EmbeddedKitManager.py”, line 199, in run
nodes = self.get_bindings_hash_list()
File “WEB/python/EmbeddedKitManager.py”, line 496, in get_bindings_hash_list
hash_list = [self._bindings.bindings[k].to_hash()
File “WEB/python/EmbeddedKitManager.py”, line 38, in to_hash
return {
IndexError: list index out of range

What’s wrong there?

I searched the forum, and found this topic:
“Xbee kit - Demo applet problem”

After reading the “How do I install and use the Embedded Kit Gateway Viewer application?” article, i would like to know, whether i need the devices listed there, like the “1-Wire Sensor Adapter”, or not ?

In my kit contains:

(1) ConnectPort X2 gateway

(3) XBee ZNet 2.5 (formerly Series 2) modules (1 XBee, 1 XBee-PRO) and (3) interface boards (1 USB, 1 RS-232)

(1) XBee wall router

I was just following the example, because i believed that it fits for my development kit. Maybe not ?

“list index out of range” normally means that one of the XBee’s associated with the gateway can’t be contacted.

This might be because the XBee is asleep (I don’t think the app was designed with a sleeping end node in mind), on a different channel, etc.

Check in the WebUI to make sure you can click on the extended address of all XBee’s associate there so you can view the basic and advanced settings. When you can click on all of them, the error should go away.

I can click on the extended address of all Xbee’s associated with the gateway. I did not change the default configuration.

You’ll likely want to call support then so we can walk you through some troubleshooting over the phone.