Gateway Demo Application Error -


I’ve just set up a drop-in networking professional development kit (802.16.4 series) and am having problems with the first Gateway application (‘discover and assign TCP sockets’).

The Instructions tell me to upload the following files: [674664 bytes] [14968 bytes] [532 bytes]

and a screenshot on the guide indicates the inclusion of the following two files: [70738 bytes] [1147 bytes]

When I run the above, I receive an error requesting a ‘’ file. I have located this on the provided CD and uploaded it to the gateway(opening it in a text editor indicates that it is identical to, bar the name).

My python applications table now looks like this:

##[x-2 setup.jpeg]##

Whilst the files have the same names, the following two have different sizes to the files listed in the manual: [674715 bytes]
and [16833 bytes]

When running this group as shown below, I receive the following error message

##[x-2 error message.jpeg]##

Any ideas on a solution or links to the correct files would be most appreciated.

Many Thanks

=====================Setup Info======================

The current network can be seen here:

##[current network.jpeg]##

It consists of:

1 Connectport x-2
1 XB pro on an RS232 board
1 XB normal on an RS232 board
1 XB pro on an usb i/f board (plugged into my laptop)

I am using getting started guide# 90000984-88_A

let me know if there is further information I can offer.

A good tutorial on installing/using the Embedded Kit Gateway Viewer app can be found here:

As for the error you’re seeing, most likely one of the nodes which “associated” with your CP-X2 is no longer available or on the network. If you power down the CP-X2 and all end nodes associated to it then power them back on, the error should be gone when you try running the Viewer app again.

Here is a list of common python errors:

Hi Admin,

Thanks for the input and helpful links.

I’m pretty sure I’ve worked it out…

Real Problem:
Me assuming that the newly delivered dev kit would have the latest firmware loaded.


I was reading ahead in the manual and noticed the limitations on firmware below 1xCx, thought my above assumption may have been flawed so updated each of my modules to the latest firmware via x-ctu (place each xbee on the USB interface in turn and update as per instructions on page 38). Ensured I powered down everything before re-trying and it seems to work.

Output from the gateway program is messy, but the PC software seems to pick it up OK. (output pic attached)

Any comments on the output would be of interest.

Once again, thanks for the assistance.

User Feedback - Might be worth making a note of this FW requirement (if it’s the true cause of the issue) in a more obvious place in the getting started guide. It was the point where the kit lost it’s ‘just works if you follow the guide’ sheen for me. Although I’m still a fan.

Message was edited by: everyunitone